Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Thread Tools Search this Thread
Old Jan 16, 2009, 8:40 AM   #1
Junior Member
Join Date: Apr 2006
Posts: 22

I had upload some photos from my D50 to Picture Project on my PC,when I was done I forgot to disconnect the camera from the PC, which I have doen before but never ran into a problem. A couple days later I went to use the camera but I could not get it to takea picture, it will auto facus make all the noises but when you hit the button nothing happens, the battery icon shows charged but began to flash, which according to the manual means the batter cannot be recognized, so I figured the battery must have drained down, so I charged it. Put the battery back in, the battery showed it was charged and the icon did not flash until I hit the button again. Also I cannot get the menu to come up, and as well I have now noticedin the view finder a small square box icon which means it cannot recognize thememory card. I have reset it, put a new card in and replaced the battery.

Any suggestionswould be greatly appreciated!
zacm is offline   Reply With Quote
Sponsored Links
Old Jan 16, 2009, 10:51 AM   #2
Senior Member
Join Date: May 2005
Posts: 1,058

This might just be one of those "rare occasions" when connecting the camera directly to the computer and not following procedures properly has created a problem. That's why many of the experts suggest that it is much safer to use a card reader. It sounds like there was some damage done when you disconnected the camera.
jphess is offline   Reply With Quote
Old Jan 16, 2009, 6:17 PM   #3
Senior Member
rjseeney's Avatar
Join Date: Dec 2004
Location: Taylor Mill, Kentucky
Posts: 2,398

First, try resetting the camera. Then, try formatting the card in camera. If neither works, try another card in the camera. If if fails to recognize a second card, there is likely somethint wrong with the camera.
rjseeney is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:22 AM.