Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Thread Tools Search this Thread
Old May 20, 2010, 8:47 AM   #1
Junior Member
Join Date: May 2010
Posts: 2
Default D50 Problem

I've been using my D50 for quite some time with any problems, but all of a sudden it won't take any pictures when set to autofocus. The lens does autofocus if I push the shutter, I can get it to take pictures if I hold the AE-L/AF-L button while I press the shutter, but that's a pain. I've tried pushing both of the green button to do a reset, but my problem didn't go away.

curtn is offline   Reply With Quote
Sponsored Links
Old May 20, 2010, 9:01 AM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,371

Are you're sure you've got enough light/subject contrast for it to lock focus?

You should get a steady focus confirmation light in your viewfinder when it's locked focus when you half press the shutter button (and it will take longer to lock focus in lower light, so if you're just quickly pressing and releasing the shutter button, you may not be giving it enough time to lock focus before you press the shutter button the rest of the way down).

Using a "Half Press" and waiting for the camera to lock focus before pressing it down the rest of the way is the preferred way to do it in lower light.

How about filters (have you installed any new filters on your lens lately)? That may be impacting the ability of the camera's AF sensors to see well enough to focus.

How about focus mode (Single Shot versus Dynamic Area, etc.)? I'd try it in Single Shot mode and see what happens, and make sure you set the AF Area to Center for testing (in case it's selecting a less sensitive outside focus point for some reason).

You may also want to try remounting the lens is case it's not making a good enough connection. Ditto for moving the AF/MF switch back and forth to make sure it's got a good connection in the AF position.
JimC is offline   Reply With Quote
Old May 20, 2010, 10:41 AM   #3
Junior Member
Join Date: May 2010
Posts: 2

Thanks. I'll try these tonight when I get home from work.
I'll let you know if it works or not.
curtn is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:20 AM.