Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Thread Tools Search this Thread
Old Apr 29, 2014, 4:30 PM   #1
Junior Member
Join Date: Jun 2005
Posts: 10
Default Strange battery problem enel3e... New battery fully charged keeps showing dead

Not sure if this is the right section, but here goes.

I just got a new battery for my Nikon d80. Charged it up. Put it in my camera. It shows fully charged, then goes dead 30 seconds later. Then I shake the camera and it goes fully charged again.. This problem keeps repeating itself over and over. This is a genuine Nikon ENEL3e, not a cheap rip off. The springs and contacts to my camera seems fine. And it's not like it's not making proper contact, because then it would show no battery.. Instead it keeps showing a dead battery. But then if I cycle the camera or maybe even just shake it, it goes back to full power. Never encountered this before. Anybody have any ideas? Thanks!
sscheinfe is offline   Reply With Quote
Sponsored Links
Old Apr 29, 2014, 4:55 PM   #2
Senior Member
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,808

G'day mate

It almost sounds like the memory-chip inside the battery has a problem - can you take it back to the shop and ask them to double-check it in another camera body?

Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Google me at Travelling School of Photography Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:20 AM.