Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Thread Tools Search this Thread
Old Jul 8, 2006, 11:08 AM   #1
Junior Member
Join Date: Jul 2006
Posts: 1

I just purchased a nikon D50 about a week ago and it had been working fine. Last night after shooting some pics I turned on the camera only to find that isnt working right. I brought it over a friends house and plugged it into his computer and it did not recognize the camera. I unplugged it from the computer and took the cable out. First even though I have my SD card in, the remaining picture number does not come up between the two parenthesis. Then I hit play and nothing comes up. Then I hit menu and nothing comes up on the screen. On the top screen the battery icon was flashing. I took the battery out (which was fully charged right before I shot the picutres) and put it back in. Still no picture number and no pictures coming up. I then took of the lens cap and tried to take pictures. It did nothing, the battery icon was still flashing. When I look through the view finder there is a square icon with a line through it and a triangle flashing. I then took the memory card(SD Extreme III 1 GB) out and put it back in. Still nothing, no pictures , no menu, nothing. So I came home and charged the battery last night. I woke up this morning and put the fully charged battery in still nothing is working. I took out the memory card and put that alone in the SD card reading slot and nothing happens. Is there anything I can do ......is it my memory card that got damaged...or is there a malfunction on the camera ?
TheMadGooch is offline   Reply With Quote
Sponsored Links
Old Jul 8, 2006, 9:45 PM   #2
Senior Member
big_potato's Avatar
Join Date: Jun 2005
Posts: 487

90% sure your SD card or the D50's SD slot problem.

Especially with the flashing |/\| icon on the viewfinder.

Try another SD, or buy a < US$10 USB SD reader to verify the problem. You will eventually need such convenient reader instead of connecting the D50 directly to the PC, even if not for this problem.

big_potato is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:25 PM.