Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon Lenses

Thread Tools Search this Thread
Old Dec 26, 2010, 7:54 PM   #1
Junior Member
Join Date: Dec 2010
Posts: 1
Default Tamron 300 2.8 SP IR lens

I have a Nikon D 300 and just purchased this lens on EBay (it's new never used) but my AF just goes back and forth and won't focus my D300 or my buddies D-3, Manual works just fine. AF just keeps moving back and forth and won't focus. Any suggestions? Dean
dinoa80 is offline   Reply With Quote
Sponsored Links
Old Dec 29, 2010, 8:04 PM   #2
Senior Member
tizeye's Avatar
Join Date: Mar 2010
Location: Orlando, FL
Posts: 382

That is an old lens and not certain the level of support Tamron supplies as not listed on their web site. You may need to contact them.

Googling, found some reviews on photographyreview.com. Notably, the March 2000 review stated that would not autofocus on the F100 (film camera) and Tamron was issuing a ROM update to correct the problem. Likewise, the April 2006 review noted that some Tamron lenses need a CPU update for AF functioning.

Given that that was before the D300 existed, it is not surprising that may not be able to communicate with normal electronic code updating Nikon would do with each new, and more complex, model release. The bigger question is - does Tamron continue to support it with the newer cameras. Given that it is not in current production, and uncertain when production ceased, how relaible is the Ebay "new" assertion?

Last edited by tizeye; Dec 30, 2010 at 5:52 AM.
tizeye is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:32 AM.