Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Thread Tools Search this Thread
Old Jun 2, 2003, 12:14 PM   #1
Junior Member
Join Date: Jun 2003
Posts: 1
Default Power Problems with Nikon Coolpix 5700

Hi, I've just been speaking to my dad who is on holiday at the moment and he is having a power problem with his Nikon Coolpix 5700. He said he can't get it to switch on at all. He has charged the batteries but to no avial. He has tried all of your usualls like taking the memory stick out and basic things like that but still no luck. So I was just wondering if anybody else has experienced this problem or has any usefull tips. Thanks for the help.
dougsmurfy is offline   Reply With Quote
Sponsored Links
Old Jun 2, 2003, 4:43 PM   #2
Join Date: Dec 2002
Posts: 71

There could be something wrong with the camera or the battery may have been damaged some how. I've had mine for over 8 months with no problems. You could also take the battery and flash card out for 48 hours and then install it back. This will reprogram everything back to its default settings. It may work or it may not, but it's worth a try.

Nikon 5700
gverde is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:38 AM.