Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Thread Tools Search this Thread
Old Jul 13, 2004, 1:28 PM   #1
Junior Member
Join Date: Dec 2003
Posts: 7

I have had this camera for about a year and a half. When I turned the camera on after inserting a new CF card the camera flashed on and then went blank. All systems were dead. Sent to Nikon for repair and incurred a $200 bill. Since this was about a third of what a 5700 could be purchased for today I thought the bill was outrageous. I really had not used the camera that much and had not subjected it to abuse.

Any one else have this type of experience with the 5700?

If it happens again and Nikon does not take care of me in a better fashion I will call the camera a loss and never buy a Nikon product again.
Sid Sher is offline   Reply With Quote
Sponsored Links
Old Aug 9, 2004, 1:37 PM   #2
Junior Member
Join Date: Jun 2004
Posts: 4

Well what did you expect Nikon to do? fix the camera for free?

The camera was out of warrenty so they did exactly what there warrenty stated.

As far as changing to another manufacturer; they all operate the same way; when the warrenty period is up you have to pay for repairs.

Unless you purchased an extended warrenty through your retailer if offered.
dadsgm23 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:30 PM.