Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Thread Tools Search this Thread
Old Jul 20, 2004, 3:31 AM   #1
Junior Member
Join Date: Jul 2004
Posts: 1

Ive had a cp 5700 for two years with no problems. Recently it has developed a serious problem. With the flash set in any mode other than off, I get a SB icon with a flashing red dot in the vf, the flash does not pop up and the shutter will not release. If I raise the flash manually it does not fire and the shutter does not release. In flash off everything seems normal. I have lost my manual so cant look this up in the t/s section. I have tryed new batteries and a different cf card, no help.
kac is offline   Reply With Quote
Sponsored Links
Old Jul 20, 2004, 7:31 AM   #2
Junior Member
Join Date: Mar 2004
Posts: 8

You can download a manual here: http://support.nikontech.com/cgi-bin...nZT0x&p_li=

Frs is offline   Reply With Quote
Old Jul 22, 2004, 2:57 AM   #3
Junior Member
Join Date: Apr 2004
Posts: 18

I have exactly the same problem with mine and it happened exactly 2 weeks after the mfg 1 yr warranty. But I probably shot 2 years worth of pics during that year. Currently on about image 18,000 or so. Thank goodness for extended warranty. When I called Nikon about this, they seemed to be familiar with the problem so it may be something that Nikon will address. Never hurts to ask. They may even cut you some slack on the repair. See my other reply at


I was able to use the camera without flash for an additional 2 months by using user sets 1,2,3 or just cancelling the flash as you did. I plan to buy the SB 600 Nikon flash with my (soon to buy, I hope) D-70 for iTTL metering. It should also work with the 5700 though maybe not as feature rich. Enjoy .......Alohadios...... jock
jock is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:38 AM.