Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Thread Tools Search this Thread
Old Oct 10, 2002, 4:28 AM   #1
Senior Member
Join Date: Sep 2002
Posts: 659
Default Problem with MCEU1 Remote and CP4500

Does anyone else have this problem ?

I use the Nikon MCEU1 remote control with my CP4500. On a number of occasions it has "lost contact" with the camera. Not falling out of the socket but the camera and the remote not talking to each other. The classic was last weekend when I ended up with 40 shots instead of three. I was shooting in continuous and as far as the camera was concerned the remote shutter button was still pressed down. I had to switch the camera off to stop it.

My distributor has been very helpful and they've sent me a replacement remote control. It seems a better fit but there is still a couple of millimetres clearance between the base of the remote plug and the camera body. I suspect that this remote was designed for the 990 and it's not quite right for the 4500.

Any comments ?
checklg is offline   Reply With Quote
Sponsored Links
Old Oct 12, 2002, 10:37 PM   #2
steve's Avatar
Join Date: Jun 2002
Posts: 2,535

I use the MC-EU1 all the time with 990 and 995 cameras. It is far from perfect even with those. It often stops "talking" to the camera and requires the camera to be turned off and on again to start working again. It is very annoying to say the least. I change the battery frequently so it isn't a low battery problem - it's just a bad design problem.

The Harbortronics DigiSnap works much better.

steve is offline   Reply With Quote
Old Oct 16, 2002, 7:18 AM   #3
Senior Member
Join Date: Sep 2002
Posts: 659

Steve, thanks for this. I've written to Nikon about this and I'll be interested to see what kind of reply I get. I'll certainly look at the Digisnap for a future replacement.
checklg is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:42 AM.