Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus dSLR

Thread Tools Search this Thread
Old May 15, 2008, 7:41 PM   #1
Junior Member
Join Date: Apr 2008
Posts: 9

I have both the Oly T-20 and T32 flash units and was wondering if they can be used efectivley with my 510.
I'd love to get the FL-50 however, I already spent my IRS $$ on the 510 and just can't until the price comes down, if at all. Any advice/techniques would be appreciated.
RDH-Cincy is offline   Reply With Quote
Sponsored Links
Old May 15, 2008, 8:39 PM   #2
Senior Member
zig-123's Avatar
Join Date: Dec 2006
Location: Cape Cod, Massachusetts
Posts: 5,070


I believe that the t20 can be used, but only in manual mode as I don't believe the pinouts oon the shoe are the same as found on the flash.

Here's a link to an article on flashes for use with the E series cameras that may prove helpful:


BTW, I would check out EBay for buying a used flash.


zig-123 is offline   Reply With Quote
Old May 15, 2008, 8:56 PM   #3
Senior Member
Steven R's Avatar
Join Date: Apr 2005
Location: Tampa, Florida
Posts: 5,829

Do not use it. The OM flashes are not designed for digital cameras, and eventually something will get fried, most likely your E510. With a significantinvestment in your camera, don't endanger the circuits.

While the OM legacy lens can be used, don't risk damage to your equipment with the OM flashes.
Steven R is offline   Reply With Quote
Old May 16, 2008, 5:27 AM   #4
Senior Member
gwillys's Avatar
Join Date: Feb 2008
Posts: 247

trigger voltage is the issue, so be sure to check it. wein safe sync is an option.

gwillys is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:27 AM.