Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus dSLR

Thread Tools Search this Thread
Old Oct 17, 2002, 12:53 PM   #1
Junior Member
gtojon's Avatar
Join Date: Oct 2002
Posts: 6
Default Olympus E-20n Repair!

:lol: I sent my Olympus E-20n in for repair after 11 months and 30,000 photos. It had a stuck shutter & some hot pixels. They received it on the 15th of october and I now have it back on the 17th and have tested it and everything is perfect. I really think it does help to be positive & send it in Next Day Air.

I really am impressed!! Thanks Olympus!
gtojon is offline   Reply With Quote
Sponsored Links
Old Dec 1, 2002, 10:08 PM   #2
Senior Member
marokero's Avatar
Join Date: Jun 2002
Posts: 769

I am fortunate to live very close by Olympus, both their headquarters and their Consumer Products Group branch (service). I took my out of warranty E-10 for repair on 11/22, and am picking it up tomorrow, 12/2. They did a complete overhaul and I'm looking fowards to shooting digital again - had to go back to film for a while :P Olympus had my E-10 fixed before their estimated time I'm a happy camper too!
marokero is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:31 PM.