Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus Micro Four Thirds

Thread Tools Search this Thread
Old Oct 17, 2014, 7:24 PM   #11
Senior Member
boBBrennan's Avatar
Join Date: Aug 2005
Location: Arlington, Texas USA
Posts: 3,512

....yeah it is Drew. ser # matches to the original, I did check it before leaving the store.
boBBrennan .. FB=> http://tinyurl.com/dxlwxfz

.......he likes Olympus, Apple MAC & SmugMug best of the choices; he likes that he has choices

boBBrennan is offline   Reply With Quote
Old Feb 17, 2016, 3:14 PM   #12
Junior Member
Join Date: Aug 2004
Posts: 4

Here's mine.Came loose last night, by great good fortune when the camera was in a bag, not hanging over a hard surface. But I have invested in several Olympus Professional lenses and do not want to expose them, nor the bodies for which I paid full introductory price, to the risk of such shoddy assembly.
I called Olympus customer service this morning, and was told they'd "never heard of this happening," and that I would be responsible for repairs at full price. As the survey cited above indicates, this failure seems to hit about 1/8 of the cameras in use, so either Olympus is incompetent or lying. Pick one or both.
I love what my M43 OMDs have done for me and my clients, but something tells me a bean counter was holding a staple gun to a construction engineer's head. Just a little threadlocker on these screws, as tiny as they are, would probably have avoided all this, but Olympus gouges us for their pennies, one time after another, costing us hundreds when the problems inevitably occur.
Looking for another system, one I can trust. Maybe time to put the neckstrap back on the D800e and grab another Nikon body. Boo, Olympus.

Last edited by agiyo; Feb 17, 2016 at 3:42 PM. Reason: Add image
agiyo is offline   Reply With Quote
Old Feb 17, 2016, 3:52 PM   #13
Junior Member
Join Date: Aug 2004
Posts: 4

Originally Posted by boBBrennan View Post
......from what I've read, to me this is interesting; it seems the left side, the offset one is the consistent piece to the fail.

Bob, mine failed on the right side. I examined the lug under high magnification and it appears that one screw either was not installed or backed out before, then the other gradually backed out till the last few threads distorted and let go.

The lug appears to be threaded, but I am not certain it is held by screws as small in diameter as they would be.

They are 1mm machine screws, unbelievable that Olympus would expect them to support a body with a lens such as the 35-100 2.0, but I've never seen a warning about that.

I know there will be no explanation from Olympus repair of why the fail nor will there be an explanation to if the repair addresses the fail with different fastening.

They assured me this very day, that they've never heard of it happening. How can one even discuss the matter with people like that?

Likely the repair will simply be re-attaching the lug in exactly the same manner as it was at manufacture.

I can see no evidence of thread locker, and the screws look to me like the size of the ones that hold my eye glasses together, with a plastic backing flange. Over time, the plastic would compress which would allow the screw tension to loosen, they'd come loose as ours have, and "Olympus never heard of it." Class action, anyone? Reminds me of Nikon's D600 debacle, but they eventually made that right.

Not a fuzzy feeling going forward and certainly an often equipment check.
To say the very least. It's a lousy feeling to commit to a serious assignment, and not be able to trust that your cameras won't fall off.
agiyo is offline   Reply With Quote
Old Feb 18, 2016, 8:52 AM   #14
Senior Member
Join Date: Jan 2012
Location: New England, USA
Posts: 2,063

wow Bob this is a scary read as a fellow E-M1 owner... makes me wonder if my refurbished is one of the re-attached ones!

If it's always the left another options is switching to a wrist strap and attaching to the right side. I've got a simple leather strap on my E-Pm2 and it is very comfortable for me, although the E-M1 would be a different story especially with the 50-200 hanging off the front.

I've gotten in the habit of leaving my quickplate on the bottom of the e-m1 as it doesn't interfere with the battery door and when I want to use the tripod it's quick and easy, I'm hesitant to adopt a setup attached to the tripod mount
in my bag: e-m1, 7-14mm pro, 14-54mm mk ii, 50-200mm mk i, 70-300mm
in my pocket: e-pm2 lumix 12-32
ramcewan is offline   Reply With Quote
Old Feb 18, 2016, 1:37 PM   #15
Senior Member
James Emory's Avatar
Join Date: Oct 2011
Location: Bay City, MI
Posts: 2,357

It appears my E-M5 has the same fastening method and why wouldn't it. I guess I'm going to be extra careful when carrying the camera. Problem is there is no early warning sign. Very poor design on the part of Olympus.
Olympus OMD-M5, HLG6 grip, Olympus 4/3rd 35mm macro lens, Panny/Leica 25mm, f1.4, Olympus 17mm, Canon Pro 9000 Mk II Printer, Canon MP990 Printer, Slik U212 Tripod, Manfrotto monopod, MMF3 converter.
James Emory is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:16 AM.