Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Jun 23, 2003, 10:35 AM   #1
Junior Member
Join Date: Jun 2003
Posts: 3
Default C 5050 lens wobble

Just got a C-5050. I noticed that the extended lens wobbles quite a bit. I arranged for a replacement to be sent and the next one had the same trait. Went to a local shop and the Olympus C-5050 demo was the same. Also noticed that many other brands (Cannon G3 for example) have a certain amount of play in the extended lens. I can't help but think that this is bad for image quality - unless the lens and CCD are coupled together.

Have any C type camera owners noted this loose lens trait??


J. Trevino :?:
J. Trevino is offline   Reply With Quote
Sponsored Links
Old Jun 23, 2003, 4:09 PM   #2
Senior Member
Join Date: Aug 2002
Posts: 1,910

It's normal on the C-7x0 series of cameras...no doubt that's it's normal on other C-Series cameras which has an exposed lens tube.

Most users find that having a filter adapter tube and a UV/Skylight filter on the camera at all times is the best for protecting the lens assembly. Some C-7x0 users have bumped their lens while extended and knocked it out of alignment so the lens gets 'stuck'...a bump in the opposite direction usually gets it working again.
Mike_PEAT is offline   Reply With Quote
Old Jun 26, 2003, 2:20 PM   #3
Junior Member
Join Date: Jun 2003
Posts: 6

I remember when the first Nikon AF leneses came out, they wobbled too! Didn't seen to affect the quality of the photos though. I do sympathise, it can be a bit disconcerting if you're use to older SLR lenses.

Phatman is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:45 AM.