Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Mar 19, 2007, 11:27 AM   #1
Junior Member
Join Date: Mar 2007
Posts: 2

Hi all - newbie here.

I recently purchased an Olympus E-20 with a vast array of accessories for a very good price.
I'm having trouble getting the pictures to download to my computer - a MacIntosh G4 with OS X 10.3.9.
I had been using a Camedia C-3020 for the last couple of years with no problems. I'd use a cable, which immediately fired up iPhoto.

IPhoto doesn't seem to recognize my new camera. The card icon does appear on my desktop, but reads as "empty."

Is my OS not compatible? I can also run system 9 on this computer, is the E-20 compatible with it, does anyone know?

many thanks!!!
Lesley2 is offline   Reply With Quote
Sponsored Links
Old Jun 8, 2007, 3:01 PM   #2
Junior Member
Join Date: Jun 2007
Posts: 4


i have a mac too.. macbook is what it is. dont have classic on it though..

sounds like you should try booting up in mac classic. try hooking up your cameras in os 9 esp if the cameras are older. if that doesnt work, maybe try a card reader or something. didnt those cameras come with software cds? maybe the cds have drivers for your cameras on them. might be worth checkin it out.

Dan_Man is offline   Reply With Quote
Old Jun 13, 2007, 11:57 AM   #3
Junior Member
Join Date: Jun 2007
Posts: 1

Olympus has software for downloading pictures to MAC's and PC's.
Try one of the links to download free software.
Also you camera might need a firmware upgrade to use these products.





ronphil06 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:37 PM.