Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Sep 12, 2003, 11:15 PM   #1
Junior Member
Join Date: Aug 2003
Posts: 15
Default c5050 delayed flash


just got a C5050 camera. Understand the delay for auto focus and aperature/speed setting on the camera. The green light comes on when you press the shutter button 1/2 way down. But when press the button all the way down to shoot, there is sometimes a long delay before the flash actually goes. Hence you end up missing many "opportunities" in dynamic scenes.

Now I came from a pure manual Olympus OM1, and am used to taking the picture when I wanted it. I realize I can go to the manual mode, but is there any way around this delay?

Even my wife's old Canon film camera with auto-flash did *not* have a delay like this.


m_ahlenius is offline   Reply With Quote
Sponsored Links
Old Sep 17, 2003, 4:21 PM   #2
Senior Member
Join Date: Aug 2002
Posts: 1,910

You should probably post more info, like what flash mode you're using.

I haven't used the 5050 myself (I use a C-700 and don't have a delay unless I'm using slow2 mode), but maybe with the 5050 it's the delay that the auto focus illuminator is lit before the camera takes the picture that's delaying it.
Mike_PEAT is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:54 AM.