Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Sep 14, 2003, 9:32 AM   #1
Junior Member
Join Date: Sep 2003
Posts: 1
Default C750 Loses Data & Time ?

I have noticed that my C750 looses date & time when I change batteries, and sometimes between power-on shooting sessions. I am moderately irritated by having to reset the data & time each time I power up after a battery change, and occasionally inbetween.

Has anyone else noticed this bug?

Picture wise - I am very delighted with the C750!
I really love the manual flexibility.

I am looking for this bug to get fixed in a software update some time soon.
Homer.Robson is offline   Reply With Quote
Sponsored Links
Old Sep 14, 2003, 9:59 AM   #2
Senior Member
Join Date: Oct 2002
Posts: 157
Default Batteries and the Oly C-7X0 series

Homer -

If your C-750 is anything like my C-730 regarding batteries, the camera will only hold internal settings for about 1 hour without batteries. I have two sets of rechargable Energizers that I rotate in and out.

If you are losing your settings after putting in a fresh set of batteries, you may be having battery contact problems in the battery compartment. Some folks complained about this a while back but I do not remember reading any solution to the problem. One thing I would look at - battery height, are they all the same? If not, consider getting a couple of sets from the same manufacturer. Thomas Distributing ( http://www.thomas-distributing.com/batteries.htm ) enjoys a good reputation for batteries. Even using the same brand batteries may not be the answer; I remember once bumping my C-730 and I lost power to the camera. I put in freshly charged batteries and all was well. My guess was that I did not have the batteries fully seated in the battery compartment with the cover properly closed and locked (tough to do considering the design.)

Alternately, you may have a defective camera and will need to contact Olympus. (I hope that's not the answer.)

Good luck!

Paul in NoVA
C-730 B-300 WCON-07
plg3 is offline   Reply With Quote
Old Sep 17, 2003, 4:30 PM   #3
Senior Member
Join Date: Aug 2002
Posts: 1,910

If you don't intend to use your camera for a long time (more than a few weeks) suggest you get a set of the original lithium batteries that came with the camera...unlike NiMHs lithium batteries don't self-discharge. Like others, I have multiple sets of NiMHs, but I also have a set of lithiums for keeping the camera settings intact.

- Check out the Oly_C-700 Yahoo Group, discussions, fun assignments for ALL C-7x0 owners (700, 720, 730, 740, 750):
Mike_PEAT is offline   Reply With Quote
Old Sep 17, 2003, 5:47 PM   #4
Join Date: Jul 2003
Posts: 95

As the others have stated you need to keep a set of batteries in the camera to keep your settings intact.Loss of power for an hour will bring the camera back to factory reset.
What I don't understand is how can it keep the settings for an hour without power and not longer? How does it keep them at all after power loss you'd think it would lose the info right away? seems odd to me unless there is an internal battery that gets charged off of my NiMh's ???
slickShooter is offline   Reply With Quote
Old Sep 17, 2003, 7:26 PM   #5
Senior Member
Join Date: Aug 2002
Posts: 1,910

Don't forget there is a HUGE capacitor inside the camera for the flash...probably most of the time it's charged to the battery voltage so it's enough to keep the settings intact for an hour while you change batteries.
Mike_PEAT is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:28 PM.