Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Mar 13, 2008, 2:34 PM   #1
Senior Member
Steven R's Avatar
Join Date: Apr 2005
Location: Tampa, Florida
Posts: 5,830

Where did all the Olympus forum readers go? There used to be a lot of good discussions on this forum; but lately they have become few and far between. Only the Olympus dSLR forum is very active.

Steven R is offline   Reply With Quote
Sponsored Links
Old Mar 13, 2008, 2:55 PM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,370

Perhaps they all bought Olympus dSLR models. ;-)

If not, maybe they'll see this thread and check in.

JimC is offline   Reply With Quote
Old Mar 17, 2008, 11:23 PM   #3
Senior Member
Tullio's Avatar
Join Date: Jan 2006
Posts: 7,370

It appears to me that this is happening on just about every forum here at Steve's (some at a greater extent than others). People post pictures, they get a lot of traffic but very few comments. I've read quite a few posts from participantsmaking the same exact comments.
Tullio is offline   Reply With Quote
Old Mar 18, 2008, 12:35 PM   #4
daniell's Avatar
Join Date: Sep 2004
Posts: 70

It´s the same in the Pana forum.

Daniel L
daniell is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:54 AM.