Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Dec 8, 2008, 5:53 PM   #1
Junior Member
Join Date: Dec 2008
Posts: 1

I've a C-5050. Love it.

I've just discovered that the tiny screws that hold the tripod mount to the bottom of the camera have come loose and disappeared. Olympus doesn't have the parts.

I used to work for Hughes Aircraft and have a good assortment of unified thread (SAE - inch) screws down almost to watchmaker sizes (what a GREAT hardware store!) :G

None of these tiny things will fit. (Some will clear the threaded socket holes, though.)

My local industrial hardware supply stops with metric #4 (#3? mm, I presume.) Too big.

1) do any of 'yall have the screw specs

2) have a suggestion for finding a replacement?


pcmacd is offline   Reply With Quote
Sponsored Links
Old Dec 10, 2008, 7:41 PM   #2
Senior Member
boBBrennan's Avatar
Join Date: Aug 2005
Location: Arlington, Texas USA
Posts: 3,512


Strange coincidence, I have a C-7070 bought 3 years ago and the same screws were missing when I took it out of the 'NEW' box.

I was really surprised at that but what I did was to use the screws from an 'OLD' PS 120 film camera I had thrown into a scrap box.

That is my suggestion, find a junk cam somewhere with the same size screws and fix the C-5050

Hope this thought helps.

boBBrennan is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:30 PM.