Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Sep 8, 2010, 8:27 PM   #1
Junior Member
Join Date: Sep 2010
Posts: 4
Default Speed up my Olympus 1050SW

Hi all!

I purchased an Olympus 1050SW about a year ago, so that I could have a camera to take on my adventures without too much fear of damaging it. In terms of being sturdy, it has been exceptional, but it is painful slow at taking photos. Does anybody know why that is? I have reset it to factory default settings, but it hasn't improved anything. Is it:

Slow memory card? It uses old M XD cards. Would it be any faster at shot to shot photos with a fast M+ card?
Is it slow autofocus? Are there any settings I could change to make it focus quicker? Any features I could switch off?
Would lower megapixels increase speed? Should I lower it from 10MP to 5MP under settings?
Should I try use manual settings? I'm not sure it even has great manual control (I doubt it) but if it does, would it be faster to use it in manual mode rather than using autofocus?

Any suggestions would be greatly appreciated. It would breathe new life back in to a trusty little camera.

Thank you for any advice you can give.

Lylepalooza is offline   Reply With Quote
Sponsored Links
Old Sep 9, 2010, 12:47 PM   #2
Senior Member
mtclimber's Avatar
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143


Changing the memory card would only marginally increase the speed of your camera. I am sorry to be the bearer of bad news, but technology has increased and cameras today are much faster.

Sarah Joyce
mtclimber is offline   Reply With Quote
Old Sep 9, 2010, 7:21 PM   #3
Senior Member
Mikefellh's Avatar
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707

P&S cameras are typically slow in terms of shutter lag (the time it takes from when you push the shutter release, till the time it actually takes the picture), and shot-to-shot time (partially due to slower media cards, but also because of slower processors).

With the 1050SW you can get an MASD-1 card:
which is an adapter that allows you to use use MicroSD cards in your camera:
For cards 4gig and more you'll need to upgrade the camera's firmware to 1.1 or else you could damage the microSD card.

Note the adapter only works in certain Olympus cameras (including the 1050SW), and does NOT work in card readers...you have to take OUT the MicroSD from the adapter to use it in a card reader, as the adapter has a different shape than standard xD cards.

The MASD-1 may have even come with your camera (I got my camera used so I don't know if it's standard or not...look for the little yellow xD shaped card).

All that being said the adapter/microSD card combo is still much slower than the high-speed CF card in my Olympus dSLR.
Mikefellh is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:44 AM.