Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Dec 27, 2003, 10:38 PM   #1
Junior Member
Join Date: Dec 2003
Posts: 28
Default Olympus c750 - Dead Pixels

In New Zealand while looking at digital camera's for one of my children, I was interested in the c750. One camera store I visited complained that they had 3 returned all just weeks old with dead pixels on the LCD screen and one other camera store visited was refusing to stock Olympus digital camera's for the same reason.

Does any one know if this is a problem with the C750 with dead pixels or maybe just a bad batch.

Under New Zealand consumer laws, those who bought the c750 are covered as they must be given a full refund or a new replacement for faulty products and while both camera stores have honoured there legal requirements under the consumer laws, they themselves have been stuck with the faulty camera's as Olympus is refusing to accept that anything is wrong with there products and is refusing to take back from the stores the camera's.

The C750 was one of a couple of choices, partly owing to the hotshoe mount and the lack of required software. I had already used a C750 belonging to a friend and found it very easy to use and the ease that it plugged into our computer with no software required to be installed made it so easy to use.

Be interested in any feed back from others as to whether this dead pixel thing is a known fault, a bad batch or just plain bad luck.

Cheers All and Happy Xmas.
Gordon. is offline   Reply With Quote
Sponsored Links
Old Dec 30, 2003, 6:18 AM   #2
Junior Member
Join Date: Dec 2003
Posts: 4

Hi Gordon!

I just posted a message with the problem you are talkibg about to the Olympus forum. I bought a C750 for christmas present and unfortunately I can confirm the dead pixels you questioned; I noticed them and being very disappointed, I'm going to return it to amazon.

Aster Moon is offline   Reply With Quote
Old Dec 31, 2003, 1:54 AM   #3
Junior Member
Join Date: Dec 2003
Posts: 28

I would be interested in any feed back you get regarding your dead pixels and whether there is any feed back from Olympus themselves or from your supplier.

Olympus or at least the New Zealand office of Olympus is refusing to accept there is a problem with there product and is refusing to refund or replace camera's affected with dead pixels leaving at least two camera stores with stock that cannot be returned to the supplier for refund, repair or replacement which ends up costing the store money as they are refunding/replacing out of there own stock.
Gordon. is offline   Reply With Quote
Old Dec 31, 2003, 9:45 AM   #4
Junior Member
Join Date: Dec 2003
Posts: 1

I am novice.Can somebody expland,what is exactly "dead pixels on the LCD screen"?
I own Oly C40. At last time, I begin to see some green spread on LCD,when taking pictures outside.
When pressing half way button green spread dissapired (images- OK)
Can I link it to "dead pixels" ?
irkag is offline   Reply With Quote
Old Jan 1, 2004, 7:58 PM   #5
Senior Member
Michi's Avatar
Join Date: Jul 2003
Posts: 176

My C-750 also has one dead (blue) pixel in the left top corner. Since it doesn't affect the picture quality I never returned it, but I'm not impressed...
Michi is offline   Reply With Quote
Old Jan 9, 2004, 4:06 PM   #6
Junior Member
Join Date: Jan 2004
Posts: 5

I'm assuming dead pixels are the same as hot pixels? If so my olympus 750 also had 2 or 3 when I bought it. The problem can be found two places. On your LCD and in your photos. I have 2 on my LCD right now but really don't care all that much.

I had 2 show up in my pictures as well but I used the pixel mapping utility in my camera to make them basically go away.

Here's some info on it:

Sometimes it occurs that some pixels on the CCD are not working properly. These defective pixels, called hot pixels, can slightly influence the image quality. Usually these are identified because they show a different colour in comparison to the surrounding pixels. Due to the construction method of sensors, it is impossible to completely avoid faulty pixels.

Pixel mapping helps prevent faulty pixels from affecting image quality. When you carry out the pixel mapping option via the menu, the camera checks the functionality of each single pixel. By comparing the response with those of the neighbouring pixels, any defects can be recognised. The location of the faulty pixel is stored in memory and the camera automatically compensates for the missing or incorrect information in subsequent exposures.

The supersonic wave filter is engaged whenever you start the pixel mapping function.
The best way to check for them is to take a picture with your lens cap on and check it on your computer. If any pixels are not black then you have hot pixels.
Greenmind is offline   Reply With Quote
Old Jan 10, 2004, 12:08 AM   #7
Join Date: Jan 2003
Posts: 75

Just like LCD screens, you get some with dead pixels and some without!

A matter of luck i suppose. This should not be the case i know. Eveyone should have a 100% ok camera.
chimp is offline   Reply With Quote
Old Jan 12, 2004, 2:21 PM   #8
Senior Member
Join Date: Nov 2003
Posts: 162

There have been reports of both bad pixels on the LCD and dead pixels on the CCD (imaging sensor). The former affects viewing quality, not actual photo quality.

I bought a C-750 in September and have really put it throught its paces. I'm disappointed w/ some of its features (lowlight AF performance, sequential speed, noise levels at higher ISOs) but I did my research and was aware of these problems before I purchased. Also, poor AF performance in lowlight and elevated noise at higher ISOs are common to virtually all digicams.

Anyway, I haven't had a single problem w/ my camera. That said, it appears that Oly's overall quality control is lacking when compared to Canon, Fuji, and Nikon. Also some reports that quality varies depending upon place of manufacturer: Japan (best), Korea, or China (worst).
jkusmier is offline   Reply With Quote
Old Jan 13, 2004, 8:37 AM   #9
Junior Member
Join Date: Jan 2004
Posts: 2

I bought a C-750 from Amazon in the UK in November. And I too have a big, blue, bloody annoying pixel smack-bang in the middle of my LCD. It's particularly annoying for me as I use the camera mostly for astrophotography so the blue LCD is much more noticeable than in most other scenarios.

The only reason why I didn't return it to Amazon was that I'd bought this camera to replace a faulty Nikon Coolpix 4300 that I'd returned earlier (faulty zoom motor). It was such a hassle returning the Nikon that I didn't bother returning the C-750 and just put up with blue dot.

PaddyBhoy is offline   Reply With Quote
Old Jan 13, 2004, 9:04 AM   #10
Senior Member
pavaros's Avatar
Join Date: Jan 2004
Posts: 484

Do you think that the some of the price difference between high street retailers and internet shops can be explained in "dead pixels" terms?

is it more common to find faults when buying online? Even when the products are advertised as "new"? :?
pavaros is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:56 PM.