Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Apr 12, 2004, 9:15 PM   #1
Junior Member
Join Date: Jan 2004
Posts: 2
Default smart media card is not working properly

I am having problems with my smart media card. I have an Olympus 3030 and the camera is not recognizing any smart media card I use. I bought a brand new smart media card and I am unable to format the card. The camera just started not to work correctly. Since the Olympus 3030 is not made any more, is it better to buy a new camera.
pompeo is offline   Reply With Quote
Sponsored Links
Old Apr 13, 2004, 12:43 AM   #2
Senior Member
Join Date: Jun 2002
Posts: 823
Default Smartmedia format problems...

Smartmedia cards should only be formatted in the camera. If you have written to the card in a card reader, you may have damaged the format of the card. The camera doesn't provide a full format, but rather does a "quick" format on the card. For that reason, you can't "fix" the card using the camera's format function.

Don't worry, though, the card can be reformatted using a utility called SMPREP that comes with Dazzle and Zio! brand card readers.
Is it possible that you wrote to the card in a card reader?

There's many posts in the card reader forum that may be helpful on this topic; just search for the Topic of this post in that forum and you should find the help you need.
lg is offline   Reply With Quote
Old Apr 19, 2004, 11:35 PM   #3
Junior Member
Join Date: Apr 2004
Posts: 1
Default C-3000 card not reading also!

I started having the same problem. I have an C-3000 camera that's a few years old now and every time I start up the camera it gives a long beep and the card icon along with the (F) format icon blinks. I had to start up several times removing and re-inserting card before I could get into a state to take pictures once again. I believe the surfaces in the camera may be dirty preventing good contact to the smartmedia card. I have not heard of any methods or devices for cleaning that surface. If there's any I'm willing to hear.
djac8272 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:05 AM.