Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Nov 16, 2004, 12:04 AM   #1
Junior Member
Join Date: May 2004
Posts: 9

My c2100uz shutter button is no longer depresssing in a smooth manner.

Although If i do it slowly I can still press half way to lock focus, but this operation is getting diffucult. There is some friction that has built up, making me have to put more force when pressung and this sometimes results in a full press i.e takes photo without locking focus.
Has anybody encounterd this and found a way to fix it.
Does anybody know how to unscrew the shutter button and clean.

I know I can send it to olumpus to get ot fixed but I heard their repair charges can be high as the camera itself.



alg is offline   Reply With Quote
Sponsored Links
Old Nov 16, 2004, 12:08 PM   #2
Join Date: Jan 2003
Posts: 78


I have two C-2100 cutaway drawings and a parts list which I shall gladly send you as an Email.
If you have some skills of fine mechanics or know somebody with those skills, you might identify and order the failing part and fix the problem yourself. The part number appears to be #144700.

Good Luck, Herbert

HerbertRD is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:18 PM.