Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old May 19, 2005, 7:31 PM   #1
Junior Member
Join Date: May 2005
Posts: 1

Hi, this is my first message, and unfortunately relating a problem with my C2100 UZ camera.
The problem is that it's been a while (some months) since I used the camera for the last time. Now I wanted to take some pictures, so I charge the batteries (the olympus batteries that came with the camera - BTW the batteries were out of the camera while not used all this time) and after a couple of seconds of turning it on, the camera turns off, then tries to turn on again (makes click noise), and then the cicle repeats.
I checked the batteries and they are all charged. I even recall the last times I used the camera, that when I moved the camera to some "strange" position it turned off. So I presume this is a problem with some of the contacts in the camera? I should have tried with 4 other batteries, but I don't have any at hand, so I'll try this tomorrow.

But anybody has any idea? Is this a know problem with olympus? Is this something serious?

Any tip is much appreciated.
daneel05 is offline   Reply With Quote
Sponsored Links
Old May 20, 2005, 5:47 AM   #2
Junior Member
Join Date: May 2005
Posts: 1

Since yesterday I have a similar problem with my C-5050. When I turn it on the lens extends, then the camera "automatically" turns off retracting the lens, turns on extendning the lens etc etc etc. I have tied to smack it witha hammer (a procedure I use with all glitches of life) but to no avail.

I did not think of the battery contactsbeingthe cause, although I changed batteries, but maybe I should give that a try with my hammer?(Any other suggestions are, however, very welcome.) Is this a well-known problem with Olympus cameras?

All the best, Pullelur

Pullelur is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:20 PM.