Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old May 21, 2005, 12:43 PM   #1
Junior Member
Join Date: May 2005
Posts: 1

I have an Olympus C4000Z which I have enjoyed for several years. Recently no picture appears on the lcd when I am framing a photo, forcing me to use the viewfinder. The lcd workes fine in the other modes i.e. immediately after taking picture or reviewing previous pictues. I must have accidently changed some setting. Any positive help will be greatly appreciated. Thanks, Don
Dongo9 is offline   Reply With Quote
Sponsored Links
Old May 21, 2005, 1:35 PM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,371

Welcome to the forums Don.

It's probably something pretty simple. Most models allow you to disable the LCD for record purposes by pressing a button. This saves battery consumption, so many users like to leave their cameras this way.

With many, you press a display button once for more info, another time to turn it off, and another time to turn it back on.

Chances are, your camera is similar. If you can't figure it out via trial and error, you may want to check your manual. If you don't have one available, you can download one from Olympus:

Olympus Manual Download Link

I'll move this thread down to our Olympus Forum , where you'll find other Olympus owners that may already know the answer.

BTW, we have a review of your model here that has a lot of the available screens and options. You may want to glance through it, too. I did notice an "All Reset" menu choice under the Setup menu mentioned that may let the camera reset itself when powered on and off. If you can't figure out what controls the display during the record mode (and it's probably something very simple), you may want to give that a try.


JimC is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:34 AM.