Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Dec 29, 2002, 12:47 PM   #1
feetr2c's Avatar
Join Date: Dec 2002
Posts: 37
Default A Request for C-4000 owners

Turn on your camera and after the lens has fully extended, GENTLY grab ahold of it and see if it feels at all loose or wiggly. Is that normal, or should it be tight :?:
feetr2c is offline   Reply With Quote
Sponsored Links
Old Dec 29, 2002, 1:12 PM   #2
Senior Member
Join Date: Aug 2002
Posts: 1,910

All the Oly cameras with extending lenses do have some wiggle...I've spent a lot of time comforting Oly owners that this is NORMAL!!!

On another note, some people have bumped their lens while extended, and have knocked it out of alignment so it doesn't retract/extend...a bump in the opposite direction fixed it.

It's suggested that you get a filter adapter tube (if one is available for your camera) and a UV or Skylight filter and keep it on the camera at all times (unless you're doing flash because the tube can block some of the flash). It not only protects the lens assembly from dings, but also from dust and scratching the lens (it's a lot cheaper to replace a scratched filter).
Mike_PEAT is offline   Reply With Quote
Old Dec 29, 2002, 2:01 PM   #3
Senior Member
Join Date: Sep 2002
Posts: 3,585

I concur with Mike about the tube adapter. I leave my Kenko tube adapter on because I may want to add filters or a telephoto lens. It does provide extra protection as a benefit.
gibsonpd3620 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:54 AM.