Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Jun 20, 2005, 1:26 PM   #1
Junior Member
Join Date: Jun 2005
Posts: 19

I think my C-3030 is dying. When i turn it on it tells me the card needs formating. Sometimes it will format sometimes not. It does this with every card I put in it. It froze on me one time and I had to take the batteries out to shut it off. Sometimes when I turn it on it says it is in TIFF, another time HQ* etc... I was getting it ready for my sister to use on her vacation to Disneyland. It would be nice if there were a quick fix someone knows about, but I really dont think that's going to happen. Batteries are full, tried several cards. ALways get the card needs formating, then sometimes it will format, sometimes not. I dont want to give my sister a camera that is going to cost her loosing pictures of her grandaughter who she only see once a year. ANy suggestions other than giving her another camera? Almost forgot, I cant turn on the LCD screen or open the menu screen. I fear it is headed to the graveyard!
snapsnap is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:39 AM.