Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Jul 30, 2005, 8:59 AM   #1
Junior Member
Join Date: Jul 2005
Posts: 1

When I turn on my Olympus Mju (Stylus) 300 Digital, the green and orange lights blink concurrently, together with beeping, even though the battery is fully charged. As I understand it, this behaviour is supposed to signify that the battery is empty.
I have measured the battery voltage to be 4.1V, and since it is a 3.7V battery, it is not empty. In addition, the camera behavious identically with an external power supply (4.8VDC).
The memory card is in order, because I have managed to extract all the pictures it contained with an usb card reader. And the camera behaves the same with and without the memory card installed.
In detail, the green and orange lights blink concurrently about 4 times a second, with a beep for every two blinks. It stops after about ten seconds, and happens in the following three situations: when I insert the battery, when I open the lens cover, and when I press the "Quick View" button.

Has anybody else had this problem with this camera (or a related model)?

Best regards,

torquil is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:33 AM.