Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Mar 24, 2003, 11:32 AM   #1
Junior Member
Join Date: Mar 2003
Posts: 27
Default C-300 produces random spots

Since a couple of months I own a Olympus C300 digital camera. I'm very pleased with this camera, except for one thing. Since last weekend, I get random "spots" (they look like drops of milk!) in pictures I take. At first I thought the lense to be filthy, buf after cleaning it nothing changed. The spots occur at random, just like the number of spots. Sometimes I can shoot 50 pictures without spots, sometimes there are more than 10 consecutive pictures with the spots in them. The number of spots is random as well; some pictures have just 2 in them, others over 50!

Could you perhaps tell me what the origin of my problem is? I already swapped my memory but that didn't work for me.

I'll attach a cutout of a picture with some spots in it, to show you how these spots look like.

I've heard from people with Canon A40, 60 and 70 about the same problems. Anybody?
Dee-ehn is offline   Reply With Quote
Sponsored Links
Old Mar 24, 2003, 5:34 PM   #2
Junior Member
Join Date: Jul 2002
Posts: 20

Just out of curiosity, are you using a fresh set of fully charged batteries?

It could be that your batteries are ending their useful life span and not providing enough current to properly power the camera.

Try a new, fresh set and see if you still get the random spots.

Please report back if it helps.

wblynch is offline   Reply With Quote
Old Mar 24, 2003, 7:37 PM   #3
Senior Member
Join Date: Oct 2002
Posts: 212


Or, if you are using flash, dust!
Lauren is offline   Reply With Quote
Old Mar 25, 2003, 12:42 AM   #4
Senior Member
Join Date: Aug 2002
Posts: 1,910

I agree with flash and dust. Check out this thread titled, "artifact in picture question" and the picture link there (look at the white blob in the centre in the water...look familiar?):

Mike_PEAT is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:40 PM.