Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Mar 19, 2006, 5:41 AM   #1
Junior Member
Join Date: Feb 2006
Posts: 1

Hi all,

I have been using my Olympus C770 for just one year. Recently there is strange problems with it. Whenever I turn on my camere its zoom goes to maximum level of Telephoto. Sometime I can use Zoom lever to push it back to Wide-angle zoom but it is back to the most Tele level automatically. Zoom lever is not functioning almost the time.

Another problem is that the shutter button is not controlled as well. There is no response when it is pressed.

Someone said bad battery may cause strange problems but I am not sure. In fact, I can use PTC Camera Controller to control my camera from my PC without any problem like the above ones.

I have been quite unhappy with this camera because of its battery lifetime and now these problems.

Could anyone have solutions or I have to take it to service.

Thanks & Regards
thanhnq is offline   Reply With Quote
Sponsored Links
Old Mar 22, 2006, 9:16 AM   #2
Join Date: Aug 2005
Posts: 55

There is no battery - it it some kind of capacitor which keeps the settings.
Remove the battery and leave the camera without it for 24 hours.
If this does not help you go and try Olympus yahoo groups. You have to be member.
Good luck!
mguergov is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:55 PM.