Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Jul 9, 2002, 1:48 AM   #1
Junior Member
Join Date: Jul 2002
Posts: 1
Default Camedia 3040 - 2 problems

I'm not angry that I went on a 4 month trip and the camera broke after 3 weeks. No, not at all.

Two big design flaws I'm wondering if anyone's solved...

If the lens cap is on, and you turn the camera on to a mode or if it turns to one while in your bag lets say, the lens tries to extend and the motor burns out grinding against the cap.

1 - any suggestions for a flexible lens cap?
2 - or some way of safeguarding the mode dial?

Also, the lens cap strap is so short as to be useless.
Webserfin is offline   Reply With Quote
Sponsored Links
Old Jul 9, 2002, 11:09 AM   #2
Senior Member
Join Date: Jun 2002
Posts: 1,050

I think the best solution to that stupid lens cap is to attache a CLA1 adaptor and screw on a skylight filter then find a cap to fit the skylight - my next purchase.

Presently I use a small piece of velcro under the camera and a small (oposite) on the cap to keep it from swinging around.

Others have put a very loose fitting cap on so as the lens pops out it easily pushes the cap off.

I've not had any problems with the cam turning itself on.

steve6 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:48 PM.