Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old Jul 13, 2006, 10:40 AM   #1
Junior Member
Join Date: Jul 2006
Posts: 1

I bought an olympus c-740 a couple of years ago, i really havnt used it that much. I was taking picutres at the park the other day and it turned off with the lens stuck out, i figured the batteries just died and i needed to recharge them, i charged the battteries and put em back in, now i get no reponse from the camera it wont turn on. I cant find a working power cord for it so i cant test it that way until i find someone who has one. Any ideas? Im thinking about taking it apart as a last resort and checking for loose wires etc..
Unklekoolaid is offline   Reply With Quote
Sponsored Links
Old Jul 14, 2006, 11:56 PM   #2
Join Date: Aug 2005
Posts: 55

Maybe there is a loose connection of the batteries in the battery compartment. Try and clean the connections. Check if everything is tight.
Of course you should try power adapter.
Good luck!
mguergov is offline   Reply With Quote
Old Sep 17, 2006, 6:59 PM   #3
Junior Member
Join Date: Sep 2006
Posts: 1

I have an Olympus C-700 UZ that keeps shutting down.
The problem lies in the microswitch on the card door not closing.
If I hold the door shut with tape or my finger, the camera stays on.
The door developed enough play in it that it won't close the switch to power the camera. Try taping the door shut or holding it shut tight with your finger.
FRETTE is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:13 AM.