Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Thread Tools Search this Thread
Old May 14, 2003, 10:21 PM   #1
Junior Member
Join Date: May 2003
Posts: 1
Default C-2100 dead pixels

I have had my C-2100 for just over a year. I love everything about it and think that it has the best features and performance of any camera.

It developed dead pixels just a couple of months after I got it. I sent it in to Olympus. They "adjusted" the ccd to eliminate the dead spots. It is now 6 months later, and it developed another nasty dead pixel (or pixels) near the center of the picture. So I sent it back to them today.

:?: Are dead pixels this common, or is this thing a lemon?

I would buy a different camera, but I can't find any that match this camera's features and performance. I take lots of hand held, full zoom pictures of my daughter's stage performances. The steady shot performs wonderfully.

Thanks, Tim
Tim60 is offline   Reply With Quote
Sponsored Links
Old May 22, 2003, 8:12 PM   #2
Junior Member
Join Date: May 2003
Posts: 2

As with laptops, all lcd's eventually end up with lost pixels...be careful that you don't press on the screen at all, even when cleaning. As for another model, I've been hunting and you're right...NOTHING compares to this great camera with the stabilizer!
sportsbug is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:16 PM.