Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Other Makes

Thread Tools Search this Thread
Old Nov 27, 2006, 12:12 AM   #1
Junior Member
Join Date: Nov 2006
Posts: 5

First Thing: Thanks for the comments Jim C. The Arcsoft CD does not give options when installing the driver. You simply l-click on the driver icon & the software does the rest. I called Arcsoft on the west coast Fri. after Thanksgiving. The tech support fellow said theirs is a stand alone software. They make it for Cannon, Fugii etc... It is the responsibility of the camera manf. to include a working or functioning driver which is added to their software after purchased from Arcsoft. He said he never heard of Innovage. Interestingly, The only name on the CD is Arcsoft. No made for "designed by" in compliance with Arcsoftor anything. He had no comment or answer for this. He just went back to the stand alone pat answer. Thats where I'm at folks. Sorry I couldn't do better.Last thought: I went to Walgreensand spoke with the floor mgr. He said they sold apprx. 100of this camera and I'm the first to return with a problem. Is my brain defective??? Or is it my Presario?? I am running Windows-XP Anyone out there?
vondansand is offline   Reply With Quote
Sponsored Links
Old Dec 26, 2006, 4:11 PM   #2
Junior Member
Join Date: Dec 2006
Posts: 1

I am g having that same problem my system says driver failure? I am running Windows Xp Home Edition. Did you find a driver that will work?
meegalito is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:35 AM.