Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Thread Tools Search this Thread
Old Jan 9, 2007, 10:36 AM   #1
Junior Member
Join Date: Nov 2006
Posts: 28

Has anyone here experienced corrupted images on their SD card using a Lumix camera? This has happened several times now. Not all the images are corrupted, but it seems that the ones that get corrupted are when I change to a different scene mode. And I can't see that there is any specific scene mode presets that it happens to all the time consistently.

Looking at the SD card in a reader, the images all have file sizes that indicate the data is there, but when clicking on the properties for each corrupted file, I can see that the EXIF data is missing.

I searchied online and found out about a program called PhotoRescue which I'm trying out now as I type this message.

Is there something easy to do to save the photos is the PhotoResuce program doesn't work?

Is this an indication of a flakey SD media card? It's a 1GB no-name brand I got from Micro Center for $15.00, so perhaps it's the card and not the camera...but since it seems the the EXIF data is missing, that makes me think it's the camera and not the card, any thoughts?
Nathan Shane is offline   Reply With Quote
Sponsored Links
Old Jan 9, 2007, 11:16 AM   #2
Junior Member
Join Date: Nov 2006
Posts: 28

I found some more info and "free" software for digital image recovery in the Media/Memory Cards section of the forum. The PhotoRescue Demo did indeed show that it can recover the corrupted images from the SD media, but I'm trying the free software at this moment and hoping to get good results and save the money.
Nathan Shane is offline   Reply With Quote
Old Jan 9, 2007, 2:03 PM   #3
Senior Member
genece's Avatar
Join Date: Jun 2003
Posts: 2,111

Some have said this app works


And IMHO corruption comes from not formatting the card regularly and /or using the cleanup or in camera editting options.

And using the camera to transfer photos.

It does not come from changing modes
genece is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:24 PM.