Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Thread Tools Search this Thread
Old Oct 28, 2004, 2:46 AM   #1
Junior Member
Join Date: Oct 2004
Posts: 1

I have emailed panny twice without reply. Freakin camera breaks, I think, one month after warranty expires. I need help. The stupid lens cover wont open. I cant take pictures. everything works otherwise. It happened when trying to take pictures of kids birthday party. The wife thinks she might have hit some button. I acnt find anything in the manual or website addressing this problem. No error message. Display shows settings but the screen is black. Is there anything to reset or try other than tossing camera.

segallc is offline   Reply With Quote
Sponsored Links
Old Oct 29, 2004, 12:32 AM   #2
Senior Member
propwash's Avatar
Join Date: Aug 2004
Posts: 277

Try taking the batteries out of the camera for at least 24 hours. This can sometimes reset some faults. When you put them back in, use new batteries or freshly charged ones if you use rechargeables.

I hope this helps you out. If have an LC33 and have had absolutely no preblems with it (so far!) Good luck.
propwash is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:28 PM.