Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Thread Tools Search this Thread
Old Nov 17, 2004, 11:50 PM   #1
Senior Member
Jake D's Avatar
Join Date: Nov 2004
Posts: 205

Jake D is offline   Reply With Quote
Sponsored Links
Old Nov 18, 2004, 12:18 AM   #2
Senior Member
bobc's Avatar
Join Date: Sep 2004
Posts: 1,433

Go on their web site and see if they have an updated driver.

Also. If your system supports USB 2.0, you may want to consider getting another reader that is USB 2.0. It will upload your images much faster.

bobc is offline   Reply With Quote
Old Nov 18, 2004, 10:37 AM   #3
Junior Member
Join Date: Nov 2004
Location: Oregon
Posts: 5

I had the same problem. FZ-20, bought a 1 gig Sandisk and the prictures were corrupt when reading from a card reader. Downloading through the carmera worked without corruption but I knew my cardreader was good and wanted to use it.

I bought another 1 gig sd, Kingmax, and it works fine in the cardreader.

So, if you can read from one of your old sd cards, your card reader is ok... it's the Sandisk that's the problem.
bruceg is offline   Reply With Quote
Old Nov 18, 2004, 11:46 AM   #4
Senior Member
digcamfan's Avatar
Join Date: Jul 2002
Posts: 3,422

A good reader is the Sandisk 8-in-1 Image Mate.

You can find them on Ebay.

Sandisk should read Sandisk!

digcamfan is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:08 PM.