Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Thread Tools Search this Thread
Old Sep 6, 2005, 9:15 PM   #1
Junior Member
Join Date: Sep 2004
Posts: 5

:sad::sad::sad:After using my Lumix DMC-FZ3 for a few months, it stopped working. When I turned it on NOTHING happened. I was told to send it to the Warranty Service Center in Illinois (I'm in Florida). They received my camera on July 6[suP]th[/suP]. When I called I was told the part needed to fix it was on back order. Today, 2 very long months later, my camera was returned. Guess what?!! It still does not work. I cannot turn it on (and yes the battery is working). According to the invoice the pc board, jack door, and rear operation unit were replaced. This "repair" cost me $102.50 because the paltry 90 day labor warranty had run out. I had to pay the money up front, that is, before they had any idea of how long it would take to repair my camera. I am frustrated and angry with Panasonic. I needed to vent before I attempt to deal with them again.
bevcat6 is offline   Reply With Quote
Sponsored Links
Old Sep 7, 2005, 10:32 AM   #2
Junior Member
Join Date: Feb 2005
Posts: 9

that just downright stinks.

My fz15 is on the fritz now (random lockups)and I am in the parts only portion of my warranty. maybe that panasonic extended warranty is the way to go. I don't have any idea what it costs but its apparent the labor prices at the service center are fairly high.
kjo43 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:18 AM.