Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax Lenses

Thread Tools Search this Thread
Old Feb 9, 2007, 5:57 PM   #1
Senior Member
IntrepidWalker's Avatar
Join Date: Jan 2007
Posts: 177

It's probaly been discussed here before, but any recommendation on these lens:

Tamron AF 70-300mm F/4-5,6 Di LD

Sigma 70-300mm f/4-5.6 APO DG MACRO
IntrepidWalker is offline   Reply With Quote
Sponsored Links
Old Feb 10, 2007, 12:20 AM   #2
Senior Member
Hayward's Avatar
Join Date: Jan 2007
Posts: 1,318

Haven't used the Tameron, but been quite happy with teh SIGMA 70-300mm on both Canon Rebel and Pentax K10D platforms.....

And AF problems definately the Rebel not really the lens(if you have heard that critisim from that camp).... nary a single AF failure or just getting lost on the K10D even in very near dark... vs completely search LOST in just low light at full zoom on the Rebel, until you zoom out some and refocus.

And again on the K10D it just fails on the rare occasion it doesn't search off into never never land and stay there... and often will get it on second or third try, again in near dark, as long as there is some light source/slightly lit area in the frame with the Sigma 70-300mm. In fact with the flash active I have yet to even have it strobe assist.

The Rebel just continuous servo drives the lens... so if you make a big zoom shift in low light it overshoots and gets lost.
In very low light the K10D (not sure about the 100 or isT's.... you don't mention your use) once it is close just makes very slight incremental steps one way or the other until it locks or fails/strobes the flash, I assume... only have it active when I intend to use it and that is close up and at least lit dimly so far, and that situation hasn't come up yet.

And especialy Rebel small target and flat background gets lost.... Pentax amazingly picks it out.... same lens diffrent mount, control/firmware.

At any rate the AF issues anyone might menton on this lens are more the camera attached to it than the lens itself.

EDIT I should add I have a 1st gen Rebel (300D) the newer XT's may be better about this.... but again not really a lens issue.... a good AF system is just fine with the SIGMA 70-300mm in low light.
Hayward is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:12 PM.