Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax Lenses

Thread Tools Search this Thread
Old Dec 26, 2008, 11:11 AM   #1
Join Date: Nov 2007
Posts: 44

Hi. Just wanted to update you on some good news. Seems that Santa thought I was good enough all year for me to get the K200d! Well, I can happily say that the issue of the M lenses shooting wide open all the time has been resolved. It turns out that it WAS the camera that was the culprit! All of my older lenses do stop-down metering perfectly on the 200d! Now I just have to remember to press the Green button instead of the Ae-L.

JBoyde is offline   Reply With Quote
Sponsored Links
Old Dec 26, 2008, 4:35 PM   #2
Senior Member
robar's Avatar
Join Date: Mar 2005
Location: D/FW area Texas
Posts: 7,590

congrats!! at least you know what it was..

robar is offline   Reply With Quote
Old Dec 27, 2008, 5:22 PM   #3
Senior Member
mtngal's Avatar
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,004

That must be a relief! And well done with the K200 - it's a nice camera.
mtngal is offline   Reply With Quote
Old Dec 27, 2008, 5:52 PM   #4
Senior Member
bigdawg's Avatar
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981

I had a similar problem with my K10D Harriet. Sent it back to Pentax and now it works great. Glad your new one is doing the job.
PS...You've always been GOOD enough!

bigdawg is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:17 AM.