Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Mar 28, 2007, 8:39 AM   #1
johnyeros's Avatar
Join Date: Dec 2006
Posts: 78

Sent it out three weeks ago and now I have to wait at least another 2 weeks.. My flashed died.. Man. I'm bored.. Anybody got a spare K100D :?!
johnyeros is offline   Reply With Quote
Sponsored Links
Old Mar 28, 2007, 11:47 AM   #2
Senior Member
Wingman's Avatar
Join Date: Dec 2003
Location: Hebron, Kentucky (northern Kentucky/Greater Cincinnati):KCVG
Posts: 4,297

I had to send my DL body to Pentax for attention in 2006. It took over 8 weeks (plus several follow-up calls) before I got my camera body back. Rapid turnaround is not their priority....I'd give them a C- at best!
Wingman is offline   Reply With Quote
Old Mar 28, 2007, 3:08 PM   #3
Senior Member
Corpsy's Avatar
Join Date: Dec 2005
Posts: 879

When I found a hot pixel on my images (mostly at high ISO), I called Pentax and found out it was covered and that they could repair it, but that it would take 6 weeks. I decided that the 6 weeks without the camera would be a bigger loss than that pixel.
Corpsy is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:06 PM.