Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Apr 13, 2007, 6:06 AM   #1
Senior Member
a200user's Avatar
Join Date: Aug 2005
Location: Western New York
Posts: 942

I just bought an AF 360 FGZ flash for a K100D. Tried it for the first time. All my shots are very underexposed in P-TTL mode. Doesn't matter if I use the K100D in P, A (aperature) or S (shutter) modes. Even if I boost the flash comp up to the max, the shots stay very underexposed. The only way I can get properly exposed shots is if I put the flash in Auto mode. Butwith the flash inAuto modeyou have tomanually adjust the flash zoom to match the lens (18-55mm DA kit lens). and you have to manually set ISO and aperature on the flash. Also, as I move the sync slider switch on the flash to the different settings, the LCD on the flash does not change to the selected sync setting. I also took the flash off the camera to check the slave function, and the flash will not give me a flash ready indication. I get the ready indication when the OFF/Wireless/On switch is all the way to ON, but not when you put it in the setting for Slave. Am I doing something wrong or is this flash defective?
a200user is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:56 PM.