Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Jul 10, 2007, 4:25 AM   #1
Join Date: Jul 2007
Posts: 93

Hello, I have a K10D and am usingan old manual lens. Now that I can get it on and off easily I'm having a lot of fun experimenting. I'm noticing two issues: the metering often overexposes, and automatic white balance isn't reliable.

I shot the same scenes using the manual lens, and the DA50-200 in sun and shade. I haven't seen any problems using auto wb with the DA lenses. WIth the manual lens the white balance is off, more so in bright sunlight. The color temperature is too cool. If I manually set the temperature in PhotoLab or the camera the colors are correct. Should AWB work with a manual lens? Any idea this is happening?

I can adjust for the metering by selecting a faster shutter speed and observing the histogram. The process I'm using is to open the aperture, focus,close down,and meter with the green button. Then I adjust the shutter speed. I'd really like to just use exposure compensation but this feature doesn't seem to work with the manual lens. Is there a better way to handle this situation?

bruder is offline   Reply With Quote
Sponsored Links
Old Jul 10, 2007, 6:41 AM   #2
Senior Member
ejbrusselsprout's Avatar
Join Date: Feb 2006
Posts: 137

hi bruder

maybe this will relate. with m lenses (i'm guessing yours are older non auto aperture lenses?) on my dl the metering is close (not perfect) using theae-l button (the same as your green button?) except with extension tubes on it's one to two stops underexposed. i just work around it by hitting theae-l button, dialling in at least one stop lower on the shutter, taking a test exposure for the histogram etc. sometimes hitting the ae-lbutton twice helps. it's a bit of a pain but hardly noticeable any more. it would be nice if exposure compensation was usable in manual mode.

on the dl you only get centre weighted metering in the manual mode which i never use otherwise. if the k-10 is similar maybe that's affecting things?

can't speak to the AWB issue as i don't use it.

all the best, eric

ejbrusselsprout is offline   Reply With Quote
Old Jul 10, 2007, 7:00 AM   #3
Senior Member
rhermans's Avatar
Join Date: Jun 2005
Location: Antwerp - Belgium
Posts: 3,454


Eric just described the way I handle the problem. I use the green button and then or change the apperture, but mostly if possible I'll change the shuttertime.

rhermans is offline   Reply With Quote
Old Jul 10, 2007, 1:41 PM   #4
Senior Member
mtngal's Avatar
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,004

I don't have problems with white balance and manual lenses, though some of my lenses are slightly different than others (my A*300 is the best lens when the sun is low). White balance and contrast tend to be influenced by the particular lens (I have an old non-SMC lens that has less contrast than any other lens, but is really sharp and actually better than a modern bright, high contrast lens in certain situations).

As far as the K10 over-exposing with manual lenses - it seems that some people report that it does, while others say theirs are fine. My particular one overexposed 2 stops or more(really signficant!) when using the green button. I read about an unautorized fix to the problem - replace the focusing screen with one from a DS. I mentioned that to a Pentax rep, who said "don't do it" andI should send the camera in for repair - the metering should be correct with all lenses, including manual lenses. I had just about decided to go that route when the DS divided screen I had previously ordered came in (less than $50), so I tried the screen first. Works fine, I likehaving the thirds lines, so I decided not to send my camera in. Pentax will tell you you shouldn't do it - having a screen not designed for the camera isn't a good idea - but I don't think it makes a difference at all and I'm now happily using all my old lenses.
mtngal is offline   Reply With Quote
Old Jul 10, 2007, 4:28 PM   #5
Join Date: Jul 2007
Posts: 93

Center-weighted metering may be tripping me up. I checked the manual and camera data and sure enough that's what is used.

White balance is puzzling. AWB is cool, manual white balance is accurate.AWB works fine (outdoors) with all the other lenses.
bruder is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:16 PM.