Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Jul 11, 2007, 10:34 PM   #1
macshak's Avatar
Join Date: Mar 2005
Posts: 91

Has anyone had problems with their 'E-dial'?

Mine has gotten to where I can hardly change the settings. I roll the dial, and the setting jump all over the place. When I mostly shoot in manual mode, this is a real pain. Petax's site says to send to nearest service center, but does anyone recommend one over the other? Thanks.

I was Looking to get the K10D to replace my DS. Found it at Quest4Cameras for $662. More than $100 cheaper than most other places. But, I can't find any ratings for Quest4Cameras. I first noticed that their accessories out outragously expensive. 1 GB SD card for $249??? What the heck? I can get one for $19.99

OK. Found some ratings for this site. Forget it! Big time Bait and Switch scammers.

Guess I will wait. :sad:
macshak is offline   Reply With Quote
Sponsored Links
Old Jul 12, 2007, 6:51 AM   #2
Senior Member
Join Date: Apr 2007
Posts: 188

Hello macshak

Check out the Marketplace at Pentax Forums as sometimes good deals are to be had there..

Perhaps there is someone selling a K10d there that you can afford..


baltochef920 is offline   Reply With Quote
Old Jul 12, 2007, 1:59 PM   #3
Senior Member
snostorm's Avatar
Join Date: Jan 2004
Location: Chicago Suburb, IL, USA
Posts: 2,769

Hi macshack,

It sounds like it's a faulty switch, but you never know. If you're convinced that you want a K10 for its features, or whatever, then I'd get one.

I would, however, send the DS in for evaluation regardless. If you can't live without a camera for a significant period of time, you might contact Pentax beforehand and ask if expedited service might be available. It's possible that the fix might not be that expensive. Of course I'm probably wrong, but you never know. . .


Edit: As an addendum, let me support something that Darren mentioned. I'll probably never give up my DS because of the TTL flash metering. I've considered adding a K100 for the SR, but the DS stays -- and even if it dies, I'd do whatever's within reason to resurrect (or replace) it.
snostorm is offline   Reply With Quote
Old Jul 12, 2007, 3:47 PM   #4
Senior Member
Join Date: Aug 2006
Location: Essex, UK
Posts: 1,868

As it is a DS, I would be inclined to get a quote, and if reasonable get it repaired. If you are happy with it a get good shots, that is.

I know, from experience, that changing is not always instantly for the best.

I got used to my DL2, then bought the K10D. Now don't get me wrong, the K10D is a wonderful camera, but it is also a very unforgiving mistress. A small error in exposure and the pic is gone forever. The DL2, you can be lazy and let the camera do it all, and the shots may be a little dark from the camera, but no blown highlights. My G/f uses it in Auto mode and rarely has any problems with blown highlighta. Me, I have to meter accurately.

I guess what I am saying (rambling) is that if you are happy with the DS - and don't forget, it is the last Pentax ever to have proper flash metering - then stay with it. Changing for the sake of it can let to heartache!

Dal1970 is offline   Reply With Quote
Old Jul 12, 2007, 9:15 PM   #5
Senior Member
Gumnut's Avatar
Join Date: Jul 2005
Location: Perth, Western Australia
Posts: 1,259

i just had the same problem

my DS started doing strange things with exposures and the e dail didnt always work
although sometimes it would
i got a quote to repair it and it needed a new main board plus reprograming

$600 + to fix (Australian)

so i got the K10d (insurance paid half)
the DS is still useable on manual if i use the settings given to me on the K10d

so i have 2 cameras now

good luck with yours
Gumnut is offline   Reply With Quote
Old Jul 12, 2007, 10:39 PM   #6
macshak's Avatar
Join Date: Mar 2005
Posts: 91

I just sent an email to a service center.

Don't kow the exchange rate for Austrailia, but $600 for repair? I'll be gettin' the K10D. Everything else is working fine except the e-dial. So maybe it won't be that much. But even if close to have the cost of a new 10D, I will upgrade.

Yes Scott, I am convinced I want the 10D. But do I need? But I really really want. Though about the 100D, but for the money, not much of an upgrade. Might as well go to 10MP.

Thanks for the replies


macshak is offline   Reply With Quote
Old Jul 13, 2007, 12:34 AM   #7
Senior Member
Hayward's Avatar
Join Date: Jan 2007
Posts: 1,318

Have you tried just spraying some contact cleaner in there (and like they say on shampoo repeat again if necessary like shampoo needs directions)

Might be a failed switch but could just be a contact oxidadion problem. Especially if you are in a humid/dusty area.
Hayward is offline   Reply With Quote
Old Jul 13, 2007, 12:11 PM   #8
macshak's Avatar
Join Date: Mar 2005
Posts: 91

Will have to try some contact cleaner. Didn't think about that. Thanks.

Service center says min $175. May send in to at least get estimate, if contact cleaner doesn't work.

Took it to work and put a drop of DeoxIt in the e-dial. 95% better. Still a little flakey, but works most of the time. At least it is now usable. Thanks for recommending the contact cleaner.

macshak is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:54 AM.