Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Aug 7, 2007, 8:12 PM   #11
Senior Member
nhmom's Avatar
Join Date: Jun 2006
Location: Southern New Hampshire
Posts: 5,202

Yes, Phil. I got ahold of them today. They can't tell me anything yet, though. The reason they couldn't find it before was they "code" it as the return name and address and I asked them to return it to my office. I kept telling them my name and zip code for home not the name of the company I work for.

I'm hoping I won't have problems. I know it was delivered on 7/30 by UPS at 8 a.m. Today they told me they "processed" it on 8/2. And, it usually takes 15-20 days for them to get to it. I asked if she meant 15-20 to ship it back or I should have it by then. She wouldn't commit to either.

At least I know they have it now. My only concern at this point is my warranty expired on 7/31. I hope they use the 7/30 "received" date and not the 8/2 "processed" date for the warranty. I will fight them on that if they do.

Will post when I get it back and what they did. I've been using my old film C and am convinced now it was the camera and not me. I've taken 4 rolls offilm this past weekend and every single photo came out just fine. So it's not my abilities. (Well, maybe just a little!):-)
nhmom is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:19 AM.