Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Aug 9, 2007, 12:04 AM   #11
Senior Member
thekman620's Avatar
Join Date: Feb 2004
Posts: 6,084

These are very good. Shows what the lens is capable of at f/2.8. Very sharp it appears to me. The high contrast shot through the window appears to have ca's, but this is understandable, and I'm not really sure if it is because of the lens or the k10d. My FA*300 shows considerable ca's sometimes using the k10d, but I never saw any on my DS or the D that I have now. This lens looks like a keeper. Looking forward to seeing some 16-50 shots in real world shooting..thanks for posting these......Don
thekman620 is offline   Reply With Quote
Old Aug 9, 2007, 1:49 AM   #12
Senior Member
snostorm's Avatar
Join Date: Jan 2004
Location: Chicago Suburb, IL, USA
Posts: 2,769

Hi Harriet,

Well you've convinced me -- but I'm an easy sell.

I also don't much like doing lens tests -- the best way I can test a lens is shoot what I like, and see how it does with that -- If I get what I consider good results right off the bat, then the lens is a keeper. This also brings out the real life handling quirks that might make the lens harder to use than I might like.

Looks like I'll be visiting my dealer tomorrow morning. . .

snostorm is offline   Reply With Quote
Old Aug 9, 2007, 7:49 AM   #13
Join Date: Jun 2007
Posts: 42

this hobby is getting expensive... :crazy:
chepburn is offline   Reply With Quote
Old Aug 9, 2007, 7:59 AM   #14
Senior Member
mtngal's Avatar
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,004

Don - you may be right about the CA being influenced by the camera. I thought the CA was pretty well controlled, better than what I've seen from the A*300 but haven't noticed whether I get the same thing with the K100 or not.

Scott - the lens is better balanced than the A*300, so I find it easier to use. I didn't particularly struggle with it in the library, despite shooting at shutter speeds slower than I should have been using. Only one of the pictures showed much for camera shake. And I still haven't tried any ISO 1600 shots yet. I didn't want to take the time to run noise reduction software yesterday, so I had changed the camera to use a max of ISO 640 or something like that (didn't let it go as far as ISO 800, my usual stopping point).
mtngal is offline   Reply With Quote
Old Aug 9, 2007, 8:06 AM   #15
Senior Member
kashka's Avatar
Join Date: Apr 2005
Location: Minnedosa Manitoba
Posts: 1,158

Wow..what a beautiful building!..and your lens captures that gorgeous architecture magnificently.I love old buildings..and I am often envious that you all in the US have such older buildings to admire.Great subject!
kashka is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:29 AM.