Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Feb 22, 2008, 4:14 PM   #11
Join Date: Jul 2007
Posts: 93

No complaints with the white balance here. I leave it on auto and adjust to manual setting if shooting under tungsten lights. It would be nice to leave it on auto all the time. If I forget to switch I can adjust later. Since I've never used another DLSR I have nothing to compare the performance to.
bruder is offline   Reply With Quote
Old Feb 23, 2008, 2:41 AM   #12
Senior Member
Lyrics51's Avatar
Join Date: Jan 2007
Location: Northwest Ohio
Posts: 1,953

I had two Kodak P & S cameras before my ist DL and both did really well with tungsten lights. The DL does not, so I am assuming it is a problem with all Pentax cameras. It just seems strange that if it can bedone right, why didn't they do it right?Howeverits reallythe onlything about the camera that causes a slight blood pressure rise!

Lyrics51 is offline   Reply With Quote
Old Feb 23, 2008, 9:19 AM   #13
Senior Member
Join Date: Mar 2006
Posts: 373

I am yet to use K10D extensively, but I noticed that AWB misses even more when doing snow scenes. I could not believe how blue some shots came out. Setting it on Cloudy took care of the issue. I find it a bit less predictable than K100D which I knew exactly before hand that it won't be able to handle certain scenes. K10D seems a bit erratic. Hope that this is isolated.

DigitalAddict is offline   Reply With Quote
Old Feb 24, 2008, 7:52 AM   #14
Senior Member
bluwing's Avatar
Join Date: Jan 2005
Posts: 592

Hi DA,

For all of my snow pics, I use a Polarizer. It works well on my istD using auto balance.

bluwing is offline   Reply With Quote
Old Feb 24, 2008, 8:36 AM   #15
Senior Member
mtngal's Avatar
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,004

I've never had a camera that handled snow pictures correctly all the time - I always take them in raw and plan on adjusting them later. I also have trouble with the exposure - because if you are shooting in snow/sunlight you'll get underexposed shots, while you'll get correctly exposed shots in the shade and I forget to change the Ev settings when the conditions change. If I have the picture correctly exposed, there seems to be less of the blue tint. But that's held true for any of the cameras I've had - the only one that seemed able to compensate was the Panny FZ30's "snow" mode - it was the only scene setting I found on that camera that was really useful.
mtngal is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:32 AM.