Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Oct 6, 2010, 4:20 PM   #11
Senior Member
MadMikeSS's Avatar
Join Date: Jul 2006
Location: Kenmore, NY
Posts: 743

Originally Posted by Odinz View Post
Well I feel stupid, feel free to ridicule me as much as you want.

Thanks everybody, I think the problem was the grip (Pentax tech didn't even think of that one when I was on the phone with them). The shutter on the grip wasn't completely in the 'Off' position (must have moved when I took it out of the holster case yesterday) my hands are pretty big and the corner of the camera grip rests in the palm of my hand. The Tokina, as well as the Bigma, are heavier lenses and push harder into my hand. When the camera was sitting on my desk the edge of the grip was up against a magazine which probably accounts for that one. The thing is while cleaning contacts on the mount, lenses, etc. last night I even took the grip off to check those contacts and didn't notice the button wasn't completely in the 'Off' position, [so now I've probably messed something else up by taking the grip off and putting it on while it was turned on ].

I'm going out tomorrow and put it through an extensive test, but I have a feeling that it is solved. At least I don't have to make a trip to Fedex on Monday.

Thanks again,
Glad you figured it out... See, I had a feeling it was the shutter release on the grip. I've done it myself lots of times.
PPG Page
MadMikeSS is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:01 PM.