Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Jul 13, 2006, 9:52 AM   #11
Senior Member
TDN's Avatar
Join Date: Jun 2006
Posts: 1,288

Sent the seller the same picture as a few posts above, and his other lens has the same cutout.

Sent the lens back now, and he will give me a full refund.

moral of the story: try to get a picture of the mount!

TDN is offline   Reply With Quote
Old Jul 21, 2006, 3:50 PM   #12
Damfino's Avatar
Join Date: Jul 2006
Posts: 74

I have exactly the same problem with the Craig 35-70mm lens that I used to use as my primary lens on my K1000. It's marked P/K A.R inside.

It's not a huge deal for me, as it's not much different than the included 18-55mm... but I was pretty surprised that the Craig lens had that and my other two old lenses (a Sigma 28mm and a Quantaray 70-210mm) didn't. I have no idea how I ended up with it - the lens is at least 20 years old. Silly me, I should have been thinking ahead to when I would buy a DSLR a couple decades later.

Damfino is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:48 PM.