Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Thread Tools Search this Thread
Old Aug 23, 2006, 8:02 PM   #1
Junior Member
Join Date: Mar 2006
Posts: 17

I just took my 6 month old DS on a trip. When I got to my destination it seemed to work fine. But the next day when I turned the camera on the LCD screen brightened but there was nothing on it. It would not display anything (no images, menu choices etc.) nothing. It still took pictures however.

Now when I got it home it seems to work fine again.

Has anyone else had thsi problem?

It is under warrenty but I hate to send it in as they will say "It worked fine for us"
Tickwood is offline   Reply With Quote
Sponsored Links
Old Aug 23, 2006, 9:34 PM   #2
Senior Member
mtngal's Avatar
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,004

That's weird. I haven't had anything like that happening, so I can't help you, other than to sympathize with your predicament. Think I'd just leave it alone unless it happens again, but then I've usually taken a "wait and see" attitude.
mtngal is offline   Reply With Quote
Old Aug 24, 2006, 3:19 AM   #3
Senior Member
Catbells's Avatar
Join Date: Nov 2004
Posts: 874

I've experienced a 'crash' where the camera just locked up and nothing worked even the off button. Removing the batteries was the only way to power it off.

I've also experienced problems with focusing which was resoled by rotating the lens with the power switched off - I found this by trial and error.

I've also experienced a failure to recognise the SD card which was resolved by removing and re-inserting.

Your problem might have been related to the condition of the batteries or just a glitch but it's strange that it appears to fine now - perhaps there something strange going on the locality of you visit - GREMLINS!!
Catbells is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:48 PM.