Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Thread Tools Search this Thread
Old May 12, 2009, 11:17 AM   #1
Junior Member
Join Date: May 2009
Posts: 2
Default Optio 330GS Bricked?

I attempted to upgrade my 330GS to the 1.11 firmware today. All was going fine until it got about 2/3 of the way through the update. At that point, the camera just shut off, and nothing I've been able to do has revived it. I've tried different batteries, taking the CF card in and out, hooking it up to my computer...but no spark of life.

I'm not sure why the firmware update didn't complete. The battery I had in during the update was freshly charged.

Is there any way to do a "hard" reset of the camera, or some way to restore the old firmware, or retry updating to the new one?

rfs13 is offline   Reply With Quote
Sponsored Links
Old May 12, 2009, 4:44 PM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,371

From your description, I think it's very unlikely you could recover from the problem. If a firmware update fails during the update process, they'd probably need to physically replace the EEPROM with another one that has good firmware on it to get the camera working again. AFAIK, there is no backup copy of firmware in the camera. So, if it's corrupted or incomplete, the camera is not going to boot.

Any number of things can cause an issue. The most likely problem is batteries depleting while the firmware upgrade is in progress. But, you could have a problem with a corrupted download. You could also have an issue with corruption that occurred when saving the .bin file to the memory card before starting the update (or a problem caused by a corrupted File Allocation Table on the memory card being used).

As a general rule, I always make sure to format any memory card I use for a firmware update before copying the firmware to it (and I use a card reader for that purpose). I also make sure to use the Operating System's "Safely Remove" or "Eject" features to save any pending writes in RAM to the memory card after copying new firmware to one.

Otherwise, you can run into issues with corruption due to incomplete writes, because some operating systems will cache writes to media (so, if you remove the memory card or camera too soon, writes may still be in the computer's memory that haven't been flushed to media yet).

Good luck with it. But, if it's dead with known good batteries after failing to complete a firmware update, it's probably "bricked".
JimC is offline   Reply With Quote
Old May 14, 2009, 9:21 AM   #3
Junior Member
Join Date: May 2009
Posts: 2

Sigh. OK, thanks JimC.
rfs13 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:32 AM.